polaroid spectra help

Whether it's a home-made instant, a Pinholaroïd or a part replacement from a model to another ... here is the DIY section!
stories
P.......
Messages : 1
Inscription : mar. 15 novembre 2016 / 16:44 pm

polaroid spectra help

Messagepar stories » mar. 15 novembre 2016 / 16:52 pm

hey, i have a polaroid spectra. something is wrong with the film battery or the camera but i have no idea and i haven't come across this problem before. so when i put the film pack in and shoot to get the dark slide out it does come out but then it keeps going and just wants to spit the entire pack of film out, one shot after the other. thus, the photos don't develop and are left blank.

any idea why this might be happening? i know the batteries are in the film but could it be the camera. i've shot a few old/expired packs on this camera and it's been fine. not sure why it's doing this now. thanks.

Avatar de l’utilisateur
Timvrhn
P.......
Messages : 8
Inscription : ven. 01 avril 2016 / 12:08 pm
Contact :
Voir la galerie photo de ce membre

Messagepar Timvrhn » mar. 06 décembre 2016 / 11:22 am

I have read about this as a reoccuring problem.
https://www.flickr.com/groups/522411493 ... 072553680/
https://www.reddit.com/r/Polaroid/comme ... tinuously/
https://www.flickr.com/groups/11961199@ ... 057844858/

My best guess is that something's stuck, as Polaroid cameras have a lot of moving parts. Try and look up a manual on http://www.butkus.org/chinon/polaroid_c ... anuals.htm


Revenir vers « Polaroid® DIY »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité