SX-70 Sonar Manual Focus Button Stuck

Discussions on the SX-70 and the entire series 500, 1000, 2000 ...
H_Nelson
P.......
Posts: 3
Joined: Fri 04 November 2016 / 16:32 pm

SX-70 Sonar Manual Focus Button Stuck

Postby H_Nelson » Fri 04 November 2016 / 17:08 pm

Hi--

I'm having problems with my SX-70 Sonar manual focus button. It won't engage unless that little metal clip (on the front of the camera) is pried up with a toothpick.

I'm willing to look inside and see what the problem is, but I'm not sure how to take the cover off the Sonar unit. Any advice? I've read there is a Sonar repair manual supplement for the SX-70, but can't find it anywhere online.

Any tips/photos/links would be appreciated!

Thanks! :)

H_Nelson
P.......
Posts: 3
Joined: Fri 04 November 2016 / 16:32 pm

Postby H_Nelson » Sat 05 November 2016 / 18:41 pm

Well, looks like I figured out how to remove the cover: the top of the sonar casing (where you insert the flash bar) has a couple of tabs that can be carefully pried apart with a tiny screwdriver--although, if I had to do it again, I'd use something plastic to safeguard against accidental scratching. Now the question is why it's so hard to get that manual focus button to engage. Everything looks OK--the only thing that looks off is there seems to be a tiny amount of vertical play in the metal rocker arm that pops out when the plastic manual focus button is pressed. Maybe it's an alignment problem....


Return to “Polaroid® SX-70 & 1000, 2000... Land Camera”

Who is online

Users browsing this forum: No registered users and 0 guests