Page 1 sur 1

Polaroid Image 2 problem

Publié : ven. 02 novembre 2018 / 17:08 pm
par pietr0
Hi Everyone! :D I've got a problem with my Polaroid Image 2
I bought it last week, and only few days ago I took the films.
Once I put them inside, I noticed that the light shield comes out in a strange way, a bit slowly and noisy but I see the "ready" LED on and I ignore it presuming it was alright.
After a while I try to shoot, and here's the rip-off, nothing comes out :(
I can hear only a slight noise but the film remains inside, does not come out, what could the problem be?

Publié : ven. 02 novembre 2018 / 20:01 pm
par xya
there was a big problem with the film cartridges. what is the date of production of your film? it's indicated on the outside of the box...

Publié : ven. 02 novembre 2018 / 20:33 pm
par pietr0
xya a écrit :there was a big problem with the film cartridges. what is the date of production of your film? it's indicated on the outside of the box...

09/18
I try to figure out on my own, at the end I opened the front of the package, insert it again, and the last four pictures comes out "fine"
I would like to link some pics but I can't

Publié : ven. 02 novembre 2018 / 23:26 pm
par xya
pietr0 a écrit :09/18
I try to figure out on my own, at the end I opened the front of the package, insert it again, and the last four pictures comes out "fine"
I would like to link some pics but I can't

that's the newest film. it should not make any problem.

if you want to post an image link, go to "éditeur avancé" just below the last message. in the new window that will open, there is a "Img" button above the message area. click on it. (img)(/img) will appear in square brackets. go between the brackets and paste your link (img)(link)(/img). should work like a charm.

Publié : sam. 03 novembre 2018 / 09:17 am
par pietr0
pietr0 a écrit :Hi Everyone! :D I've got a problem with my Polaroid Image 2
I bought it last week, and only few days ago I took the films.
Once I put them inside, I noticed that the light shield comes out in a strange way, a bit slowly and noisy but I see the "ready" LED on and I ignore it presuming it was alright.
After a while I try to shoot, and here's the rip-off, nothing comes out :(
I can hear only a slight noise but the film remains inside, does not come out, what could the problem be?

Hope this can help
https://drive.google.com/open?id=13NUbZuSAgPF9-IuoaVN51t5kKrBi_4bd those are the first two pics, I had to extract them by hand
https://drive.google.com/open?id=1wimSu0p6uLOGdnsIUbOimb1Iar46yiYQ as you can see, the led in on, so there's voltage
https://drive.google.com/open?id=1_SgHvfu3J4ZEZYolJoDWZ5k-uRmlaUQU expire data 09/10
https://drive.google.com/open?id=19frwAt9GyvMJYqiNEReXbC9s83tG-WHZ then I opened the front, insert them once again
https://drive.google.com/open?id=1xIsqf5ijMGEOUoFx_YM7xc6FLHSgbx3R the light shield comes out very strange and it stucks at 2/3 of th way. in fact come films remain stuck
https://drive.google.com/open?id=1_bHk7NwUpHtXjhp8oHBpxnOO-O1as6cC after opening the front, the last 4 pics come out "fine"
the 5th anf 6th they were a test, I was in front of the mirror with the flash so not a good idea, the 7th I tried to do a pic outside so you can see only the roll-up shutter, and the last one came out nice, I think. That's it

Publié : dim. 04 novembre 2018 / 13:32 pm
par Meaulne
Hi pietr0, here is a link to a Polaroid spectra Manual repair, it's not the same model as your but if that can help...

edit : I've just found an other manual repair ; initially these manuals were hosted byhttp://www.everythingretek.com/PRDLibrary/LIBRARY8 but it's dead now, fortunately i've download some long time ago

Publié : dim. 04 novembre 2018 / 18:49 pm
par pietr0
Meaulne a écrit :Hi pietr0, here is a link to a Polaroid spectra Manual repair, it's not the same model as your but if that can help...

edit : I've just found an other manual repair ; initially these manuals were hosted byhttp://www.everythingretek.com/PRDLibrary/LIBRARY8 but it's dead now, fortunately i've download some long time ago

Thank you so much Meaulne :) but I'm not sure whether to send it back or keep it, we'll see