Page 1 sur 1

Film stuck in Rollers at End of Ejection

Publié : lun. 19 décembre 2016 / 02:52 am
par sddarkman619
I'm buying polaroids lately and I have one that spits outs the black layer fine, but after that the film will get stuck in the rollers at the very end. When I clear and reset sometimes it shoots and ejects fine for a couple, or sometimes it does it again. It's intermittent. AND it's very hard to pull them out. sometimes I have to rotate the gear to get it to come out. sometimes the roller will not push it out it just turns. It almost seems like the film is too thick on the end. but it all works fine on the other cameras I have. and it's only at the end. Sometimes it makes a slow whiring noise as it's trying to push it out but it's stuck.
I've looked at the gears that I can see, the pick arm is fine. the rollers are fairly clean too. See photos. Any help appreciated.
PS I've been using spent film to reload and shoot with several packs and it happens in all packs.
I have been scouring the internet and forums for several hours and found nothing specific to this issue.

Image

Image

Image

Image

Publié : lun. 19 décembre 2016 / 13:20 pm
par xya
welcome to the forum. I never had this problem, but I will try to give you some hints. are the cassettes that you are using new ones, of recent production dates? older film has sometimes weak batteries. some camera models are dependent on strong batteries. the film is thicker at its end, so it is some strain for the camera to push it through the rollers. it could also be that the camera itself has worn gearing. if it's a cheap one like the one step on the photo, just replace it by a better one.

Publié : lun. 19 décembre 2016 / 18:31 pm
par sddarkman619
the cartridge was brand new. The other rainbow one steps I have don't have this problem, only this one. Probably sell it as decoration instead of usage. and it is the camera in the photo.
thanks

Publié : mer. 21 décembre 2016 / 16:18 pm
par mimi_club
I suggest to clean both rollers - not only the golden one, but also clean the silver one.

Also try to 'push' the rollers by fingers - easy to make both rollers to move? or stuck?

(Sorry for my bad English, I hope you can understand)