Search found 8 matches

by twisel
Wed 14 February 2018 / 09:50 am
Forum: Welcomes and Introductions
Topic: Bonjour de France !
Replies: 10
Views: 1460

:)
by twisel
Sun 11 February 2018 / 13:31 pm
Forum: Welcomes and Introductions
Topic: Bonjour de France !
Replies: 10
Views: 1460

phgalano wrote:très bel Instagram, avec des modèles qu'on aime bien ...

Tu connais certains de mes modèles ? :)
by twisel
Sun 11 February 2018 / 13:29 pm
Forum: Welcomes and Introductions
Topic: Bonjour de France !
Replies: 10
Views: 1460

Ok ok ! Je comprends mieux :)
by twisel
Sat 10 February 2018 / 15:55 pm
Forum: Welcomes and Introductions
Topic: Bonjour de France !
Replies: 10
Views: 1460

Merci !
Y a que des français ici ? Je croyais m’être inscrit sur un forum international :)
by twisel
Sat 10 February 2018 / 15:13 pm
Forum: Polaroid® SX-70 & 1000, 2000... Land Camera
Topic: SX-70 - shutter won’t close during ejection
Replies: 2
Views: 776

I opened the shutter box and saw the shutter leaves were glued... I tried to unglue them, but it's not working, I think something in the mecanism is wrong too since it was forcing the glued leaves for I don't know how long... :arf: j'ai ouvert le compartiment de l'obturateur et les feuilles de l'obt...
by twisel
Sat 10 February 2018 / 01:39 am
Forum: Welcomes and Introductions
Topic: Bonjour de France !
Replies: 10
Views: 1460

Merciiiii ! :)
by twisel
Sat 10 February 2018 / 00:44 am
Forum: Welcomes and Introductions
Topic: Bonjour de France !
Replies: 10
Views: 1460

Bonjour de France !

Hi everyone!

I’m a complete newbie in the Polaroid world.
I dreamt about it for years and I finally just bought a SX-70!

Unfortunately it doesn’t work properly... (I opened a topic about it in the SX-70 section)

So welcome to me and I hope I will fix the problem ! :)
by twisel
Sat 10 February 2018 / 00:38 am
Forum: Polaroid® SX-70 & 1000, 2000... Land Camera
Topic: SX-70 - shutter won’t close during ejection
Replies: 2
Views: 776

SX-70 - shutter won’t close during ejection

Hi! I just bought a SX-70 and when I tried it, just a small part of the image was visible at the bottom. The other part was white, completely over exposed. I checked google for hours and hours, but couldn’t find a similar problem. I noticed that the mirror stays up during the ejection of the exposed...

Go to advanced search